KC 8 command line auto import?

KC 8 command line auto import?

Postby gmichael » Thu Apr 07, 2016 10:16 am

Hello,

According to Kofax documentation, auto import can be easily implemented by calling SCAN from the command line:

SCAN -i:path/name of a text file with the list of files.

Every row contains name of batch class, some parameters and file path, in accordance with KC 8 help.
File paths are less than 127 symbols long.
However, when I run it, I see some blinking screen and that's all. No batch is created, no auto import.log.
How can I trace what happening and where's the problem?

Thanks!
Sincerely,
Michael
gmichael
Participant
 
Posts: 30
Joined: Wed Feb 06, 2008 8:21 am
Location: Israel

Re: KC 8 command line auto import?

Postby russell@centuryc.com » Thu Apr 07, 2016 4:27 pm

Wow. That's a new feature on me. The closest I know of is ACXML, but 1) It's not "Scan" you call, and 2) it's a XML file, not a text file.
Russell
russell@centuryc.com
Participant
 
Posts: 3374
Joined: Wed May 17, 2006 12:53 pm
Location: USA

Re: KC 8 command line auto import?

Postby gmichael » Thu Apr 07, 2016 10:06 pm

Hello Russell, thanks a lot for the answer!

It is described in:

http://www.capture-experts.com/documents/Kofax_Administrators_Guide_v10.pdf

Page 233:

To auto import image files and index data, you must have an auto import ASCII text file and an optional .ini file. The ASCII text file must contain the index data and the paths/file names of the files to import. You can store additional batch information (such as the batch name, batch description, and priority) in the optional .ini file.

Page 234:

You can launch the Scan module to import image files and index data with the following command:
SCAN -i:Path\TxtFileName -w:hWnd –m:MsgID
Where:
-i:Path\TxtFileName
This is the path and file name of the text file that contains the index data and the locations and names of the image files to import.
-w:hWnd
This is the window handle of the application to receive the “auto-import is complete” message. Specify this parameter in decimal format, rather than hexadecimal.
-m:MsgID (optional)


Am I missing something?
Thanks!
Sincerely,
Michael
gmichael
Participant
 
Posts: 30
Joined: Wed Feb 06, 2008 8:21 am
Location: Israel


Return to Kofax Capture General Discussion

Who is online

Users browsing this forum: Google [Bot], Yahoo [Bot] and 6 guests