Service Unable to Open XML File

Ascent Collection Server

Service Unable to Open XML File

Postby SWB » Wed Feb 18, 2009 12:06 pm

Hello. I'm using ACS with DES. Everything in DES is configured properly and I have full communication with Kofax Capture. After I scan and submit in DES, my batch does not appear in batch manager. No errors logged in DES. In looking at the Kofax Capture logs, I find in the error log the following:

"2009-02-18 14:51:24, 0x00000018, 0, 0x0000000F, 0x00002328, 0x00002337, D:\Program Files\Kofax\CaptureSS\ServLib\Bin, Kofax Capture Scan, KOFAXCAPTURE, 8.00.461, , 0, Xml file cannot be opened (D:\Program Files\Kofax Capture Import Connector - Web Services - Web Server\web\BatchStorage\fbfc3bce-b093-4977-a4ed-1a211c2b5c66.xml) [ 9015 - Application-defined or object-defined error ], , "

So it looks like the problem lies within ACS and the "Kofax Capture Import Connector - Web Services - Service" Windows service. This Windows service is using the user ACICservice and has full administrative rights. It also is setup to log on as service (followed directions exactly in setting up this user and assigning rights and permissions).

I found in the Knowledgebase, DES you may receive the error if file compression has been set on the XML files or the folder containing the XML files (http://knowledgebase.kofax.com/faqsearc ... QAID=11510). I do not have compression enabled. Finally Everyone has full rights to the folder where the files live (in my case D:\Program Files\Kofax Capture Import Connector - Web Services - Web Server\Web\BatchStorage) and the Kofax Capture Import Connector - Web Services - Web Server folder is shared with Everyone granted full rights.

The XML file and image folder look fine. Anyone come across this before? I haven't ran into this issue with DES before.

Thanks for any help!
SWB
Participant
 
Posts: 103
Joined: Tue Sep 23, 2008 10:33 am

Re: Service Unable to Open XML File

Postby SWB » Thu Feb 19, 2009 7:23 am

Follow-up: I needed to enable Indexing Service to index the BatchStorage folder (folder Properties, Advanced). Each XML file has to have this enabled, so each time an XML file is written to that folder that option is checked. I assume because I didn't have the Indexing Service Windows Service running (normally I have it disabled) it wasn't indexing any files or folders.

I'm glad I was able to determine the issue and resolve it, but this is kind of one-of-those things you ask why it must be like this. Or maybe during installation and folder creation Kofax should enable indexing. Oh well...problem resolved :D
SWB
Participant
 
Posts: 103
Joined: Tue Sep 23, 2008 10:33 am


Return to Kofax Capture Import Connector

Who is online

Users browsing this forum: No registered users and 1 guest